• m

    millions-journalist-34868

    7 months ago
    I wrote an article that talks about provisioning an Azure SQL Database with Active Directory authentication configured. It also shows an example of using the new Command provider in preview. The source code used in the article is available in this GitHub repository. Many thanks to those who help me by answering my questions to write this article.
    m
    l
    4 replies
    Copy to Clipboard
  • c

    clever-byte-21551

    7 months ago
    I was trying to migrate from 1.11.0 to 1.59.0 in azure native and I noticed that since this upgrade my AKS cluster is being recreated over and over again it says there’s a change in agentPoolProfiles, the way we create our AKS clusters is configuring a single agentPoolProfile on the 
    ManagedCluster
     and we create a coupe of additional agent pools using the 
    NewAgentPool
     api. I suspect that this causes us to recreate the cluster, when I downgraded the provider plugin it was back to normal We keep seeing this diff in the logs:
    aks updated [diff: ~agentPoolProfiles]
    I don’t want to add to ignoreChanges the agentPoolProfiles because this will hinder our ability to mutate the stack
    c
    5 replies
    Copy to Clipboard
  • b

    better-forest-70644

    6 months ago
    Is PostgreSQL Flexible Server is available in the Azure Native right now ? I have searched for it and couldn't able to find that. But got some information that it's available in a preview (@pulumi/azure-native/dbforpostgresql/v20200214preview). So is it ok the use that preview to create PostgreSQL Flexible Server ?
    b
    1 replies
    Copy to Clipboard
  • c

    clean-alarm-24426

    6 months ago
    Good morning all. My Google-Fu is just not working recently. I'm setting up a fairly simple stack where I want to set resource names based on data set in an Azure Pipeline. That data could potentially come from a YAML defined parameter, a YAML defined variable, or an Azure Pipeline variable group. Can someone point me to some documentation about how to access this data from inside the Pulumi .NET app? Do I need to run a PowerShell script to set environment variables? Does the Pulumi AZ Pipelines task provide a mechanism to do this that I've just missed? Is there a method that is considered best practice?
    c
    f
    3 replies
    Copy to Clipboard
  • a

    abundant-book-94104

    6 months ago
    In Azure there are function Apps and functions. Does pulumi have functions as a component of azure to be created? I'm not seeing it and I'm not 100% sure what's the difference, but they are there
    a
    t
    +1
    3 replies
    Copy to Clipboard
  • l

    little-apartment-30401

    6 months ago
    Anyone have any good patterns for providing a “library” engineers can import so they get all their resource tagging for free?
    l
    2 replies
    Copy to Clipboard
  • l

    lively-gigabyte-52811

    6 months ago
    Hello, currently trying to convert some arm templates to pulumi using arm2pulumi. Seems like it has some problems with my template variables. What is the current state of arm2pulumi and will you open source it? Would love to contribute. My customer has quite a library of arm templates, so it would be nice to have the cli available.
    l
    g
    4 replies
    Copy to Clipboard
  • m

    millions-journalist-34868

    6 months ago
    If someone could confirm this is the right way of getting the tenant id https://github.com/pulumi/pulumi/discussions/9126, that would be great.
    m
    1 replies
    Copy to Clipboard
  • b

    bulky-kite-69343

    6 months ago
    Just curious if anyone else has ran into this when trying to provision multiple subnets against a vnet with azure-native
    Diagnostics:
      azure-native:network:Subnet (scanning):
        error: autorest/azure: Service returned an error. Status=<nil> Code="AnotherOperationInProgress" Message="Another operation on this or dependent resource is in progress. To retrieve status of the operation use uri: <https://management.azure.com/subscriptions/***/providers/Microsoft.Network/locations/***/operations/***?api-version=2020-11-01>." Details=[]
    I am kinda stumped it always seems to deploy 3 of 8 subnets each time and fails on the rest all with the same error.
    b
    g
    2 replies
    Copy to Clipboard
  • w

    wooden-receptionist-75654

    6 months ago
    Hi Guys, I have a question about Azure AKS Preview features. How can I use it with Pulumi cdk? For example
    oidcIssuerProfile
    w
    1 replies
    Copy to Clipboard