• r

    rough-window-15889

    3 months ago
    Has anyone had issues with the azure dev ops pipelines Pulumi task not setting the Pulumi access token? My runs occasionally randomly fail and won't set the token to authenticate to Pulumi. Once it happens I have to rebuild that agent it ran on them it is good.
  • c

    curved-eye-56312

    3 months ago
    message has been deleted
    c
    b
    8 replies
    Copy to Clipboard
  • c

    creamy-judge-53688

    3 months ago
    Hello 👋 I think there might be an issue with
    azure-native:network:LoadBalancer
    , and would love some clarity. Specifically I am trying to add IP addresses in the
    BackendAddressPool
    field, but these are not reflected in Azure portal and the backend has no IP addresses. Your examples don't actually populate IP addresses. I see some others use the more specific
    azure-native:network:LoadBalancerBackendAddressPool
    but I cannot use this as my
    LoadBalancer
    rules need to reference the backend pool, which it cannot do unless I create it in the LoadBalancer. Any pointers at all would be much appreciated, thank you!
    c
    c
    3 replies
    Copy to Clipboard
  • f

    flaky-yak-39108

    3 months ago
    Hello All, I am trying to retrieve my Azure subscription ID within Pulumi using the typescript
    azure-native
    library and using the
    getClientConfig({})
    function. But i am getting the following error response
    Error: invocation of azure-native:authorization:getClientConfig returned an error: getting authenticated object ID: Error parsing json result from the Azure CLI: Error retrieving running Azure CLI: WARNING: This command or command group has been migrated to Microsoft Graph API. Please carefully review all breaking changes introduced during this migration: <https://docs.microsoft.com/cli/azure/microsoft-graph-migration>
    Is there another way to retrieve the subscription ID or to avoid it all together, i need it for child processes that are referenced via azure ID
    f
    1 replies
    Copy to Clipboard
  • c

    curved-pharmacist-41509

    3 months ago
    Are there any workarounds to the really slow TypeScript type checking time for the azure-native SDK? There is almost 2million lines of type defs loaded which means the fs and parsing time for a simple program is almost 6 seconds on my MBP
    c
    1 replies
    Copy to Clipboard
  • g

    gentle-airplane-84691

    2 months ago
    Hello, any example on getting/creating service bus queues?
  • g

    gentle-airplane-84691

    2 months ago
    but i still get an unhandled error
    Status=404 Code="EntityNotFound" Message="Queue does not exist"
  • a

    ancient-solstice-53934

    2 months ago
    Hi Team, I am creating Azure resources using Pulumi and .Net code. It was working fine earlier but now throwing following error ...runtime: VirtualAlloc of 8192 bytes failed with errno=1455 2022-06-29T06:23:03.6799320Z fatal error: out of memory 2022-06-29T06:23:03.6799446Z 2022-06-29T06:23:03.6799668Z runtime stack: 2022-06-29T06:23:03.6815219Z runtime.throw({0x265343d, 0xc18c848000}) 2022-06-29T06:23:03.6815922Z /opt/hostedtoolcache/go/1.17.11/x64/src/runtime/panic.go:1198 +0x76 2022-06-29T06:23:03.6816312Z runtime.sysUsed(0xc18c848000, 0x2000) ..................
    a
    1 replies
    Copy to Clipboard
  • a

    ancient-solstice-53934

    2 months ago
    Is there any way to enable Synapse Link in Azure Cosmos DB containers using Pulumi and .Net code?
  • m

    most-mouse-38002

    2 months ago
    Trying to run https://www.pulumi.com/registry/packages/azuread/api-docs/applicationpassword/#look-up but I just cannot for the life of me figure out the format of the ID here. Specifically I have no idea what type should be in
    {objectId}/{type}/{subId}
    . edit: nevermind, for obvious reasons one cannot import this between different stacks from Azure 🙂