# azure


05/08/2023, 6:16 AM
Hello, I'm upgrading from
v4 to v5 and I'm running into a panic from the terraform provider:
Copy code
panic: interface conversion: interface {} is nil, not []interface {}
    goroutine 88 [running]:
    <{0x7ae1400|{0x7ae1400>?, 0xc00040cf90?}, 0x669bb80?, {0xc002184990?, 0x7ae1400?})
        /home/runner/go/pkg/mod/ +0x2fe
    <{0x7adef78|{0x7adef78>, 0xc000138028}, 0x2?, {0x6622f40, 0xc00041dc00})
        /home/runner/go/pkg/mod/ +0x64
    <{0x7adef78|{0x7adef78>, 0xc000138028}, 0x0?, 0xc001480d80?, 0xc000efc2a0?, {0x6622f40, 0xc00041dc00})
        /home/runner/go/pkg/mod/ +0xa7
I searched the slack archive and found 2 other people mention it but no followup solutions 1. 2. I can't find the corresponding version of the code in
because there's no
tag and that number seems wrong (in the logs) given v5 of the
package is using the provider at version
If I look at the code for
then it seems like there's a nil reference issue on this line of code: In my pulumi state i have the following under the state outputs for my cluster
Copy code
"roleBasedAccessControl": {
                        "azureActiveDirectory": null,
                        "enabled": true
And verbose pulumi output shows that it's being passed as a terraform input to the provider
Copy code
I0508 15:44:02.523773 1459043 log.go:75] eventSink::Infoerr(<{%reset%}>I0508 15:44:02.523744 1459133 schema.go:492] Created Terraform input: role_based_access_control = map[enabled:true]
I also tried removing the field from the state file and attempting to preview on that but it still fails with the same panic on the same line. Has anyone else hit this issue and know the solution?