https://pulumi.com logo
#aws
Title
# aws
a

able-flag-79751

05/30/2023, 12:58 PM
Hello everyone. I have some resources especially task Definitions that I have manually deleted on my aws ecs console page. Now that I’m trying to destroy all resources (
pulumi destroy -s <my-stack>
), I can’t get them destroyed as it can’t successfully delete those resources that I’ve manually deleted on the aws console. I also tried to delete the stack entirely (
pulumi stack rm <my-stack>
), and it’s the same error I’m getting. Please see image below for more info:
b

billowy-night-21439

05/30/2023, 1:01 PM
remove the manually deleted resources from state first,
pulumi state delete urn:XXXXXXXXXX
a

able-flag-79751

05/30/2023, 2:29 PM
Thank you, but I’m now getting this error:
Copy code
idmcalculus@MacBook-Pro-5 infra % pulumi state delete urn:pulumi:dev::swapfx::awsx:x:ecs:FargateTaskDefinition$aws:ecs/taskDefinition:TaskDefinition::dev-api
 warning: This command will edit your stack's state directly. Confirm? Yes
error: No such resource "urn:pulumi:dev::swapfx::awsx:x:ecs:FargateTaskDefinitioncs/taskDefinition:TaskDefinition::dev-api" exists in the current state
b

billowy-night-21439

05/30/2023, 2:39 PM
pulumi refresh
should clear that up so
a

able-flag-79751

05/30/2023, 2:39 PM
Thanks so much
b

billowy-night-21439

05/30/2023, 2:39 PM
no worries
a

able-flag-79751

05/30/2023, 2:41 PM
So I had like a parent task that needed to be deleted first. I was able to identify that and
pulumi state delete urn:XXXXXXXXXX
worked
Thank you again @billowy-night-21439
@billowy-night-21439 another nightmare 😢