https://pulumi.com logo
#aws
Title
# aws
a

adamant-terabyte-3965

06/09/2023, 9:22 PM
Hello, I am trying to install Karpenter on an EKS cluster through Pulumi using a
k8s.helm.v3.Release
and can't get the Release to pull the appropriate image from the OCI repo. If I'm using the old HTTP Karpenter repo (which only provides up to a year old version of Karpenter) everything is fine, but when I try and get the most recent versions I can't. I'm using the following code snippet:
Copy code
new k8s.helm.v3.Release(
    name,
    {
        name: 'karpenter',
        chart: '<oci://public.ecr.aws/karpenter/karpenter>',
        namespace: namespace,
        version: 'v0.27.0',
        values: all([endpoint, clusterNameOut]).apply(([clusterEndpoint, clusterName]) => ({
            serviceAccount: {
                name: serviceAccountName,
                create: false
            },
            aws: {
                clusterName,
                clusterEndpoint,
                interruptionQueueName: clusterName,
                defaultInstanceProfile: instanceProfile
            }
        }))
    },
    { provider, dependsOn: [albDependency] }
I'm under the impression that helm Releases in Pulumi do have OCI support, but I'm met with
error: failed to pull chart: Unable to locate any tags in provided repository: <oci://public.ecr.aws/karpenter/karpenter>
if I do not specify the version and
error: "karpenter" has no deployed releases
if I do specify the version. I think this is possible, but don't understand what I'm getting wrong. Please advise!
b

billowy-army-68599

06/09/2023, 9:39 PM
if you do
helm ls
on the namespace, do you see any releases?
a

adamant-terabyte-3965

06/09/2023, 9:50 PM
yes, with status
failed
b

billowy-army-68599

06/09/2023, 9:56 PM
delete that, then try again with the tag
a

adamant-terabyte-3965

06/09/2023, 10:19 PM
so I tried deleting the failed Helm Release, and got this error:
Helm release "luketest-serve-karpenter-ns/karpenter" was created, but failed to initialize completely. Use Helm CLI to investigate.: failed to become available within allocated timeout. Error: Helm Release luketest-serve-karpenter-ns/karpenter: timed out waiting for the condition
, and then tried tearing down the cluster and building from a clean slate and got the same error?
I'm a little more confused based on this Github issues thread which the code snippet used seems pretty similar and works for them https://github.com/pulumi/pulumi-kubernetes/issues/2334
Hm, so after examining the pod logs for the Karpenter controller there was an error in the
values
field, and after fixing that the image was pulled from the OCI repo so I don't think this is a Pulumi issue, thank you for your help!
11 Views