https://pulumi.com logo
#aws
Title
# aws
p

plain-oxygen-47046

06/20/2023, 9:31 AM
Hi, We are facing a very wired issue, hope that someone can help 🙂 We have an old stack that contains secrets, roles and an RDS. That rds built as a custom resource and include cluster, 2 instances, secret, secret version route53 record and random password. For some reason when we are running
pulumi refresh
pulumi doesnt recognize part of resources and then deletes them from the stack. It doesnt recognize the RDS cluster, instances and secret but do recognize the route53 records and the random password. I loaded the old version of the stack from s3 and it it reproduce. Things that i already check: • no wired changes done in the stack • ARN of the resources are correct • It reproduces in different state type (i download the stack to local state and it is the same ) • Plugin version is 5.4.0 I tried to upgrade the plugin but ◦ The plugin store as part of the state and upgrade locally didnt help ◦ The plugin probably worked fine when we deploy it in the first place ◦ I cannot upgrade plugin without running "up" on all the resources what fail due to the "already exists" issue Will appreciate your help