https://pulumi.com logo
#general
Title
# general
c

creamy-ambulance-91738

06/28/2023, 3:24 PM
Hey team, just wondering why the pulumi cli describe format is a bit funky. When I run "pulumi up" I get the following (correct) hierarchy:
Copy code
Type                                 Name                                    Plan       
 +   pulumi:pulumi:Stack                  cloudflared-tunnels-sandbox             create     
 +   ├─ components:tunnels:Tunnel         gb-lon-li-cfdtunnel                     create     
 +   │  ├─ random:index:RandomId          gb-lon-li-cfdtunnel-argoSecret          create     
 +   │  └─ cloudflare:index:Tunnel        gb-lon-li-cfdtunnel-tunnel              create     
 +   ├─ components:tunnels:Tunnel         blease-test                             create     
 +   │  ├─ random:index:RandomId          blease-test-argoSecret                  create     
 +   │  └─ cloudflare:index:Tunnel        blease-test-tunnel                      create     
 +   ├─ components:tunnels:TunnelRoute    blease-test                             create     
 +   │  └─ cloudflare:index:TunnelRoute   blease-test-route-192.168.1.0/24        create     
 +   └─ components:tunnels:TunnelConfig   gb-lon-li-cfdtunnel                     create     
 +      └─ cloudflare:index:TunnelConfig  gb-lon-li-cfdtunnel-tunnel-config       create
However when I go to describe the stack the indentation/ordering is off. cloudflareindexTunnelConfig is under componentstunnelsTunnelRoute:
Copy code
+ pulumi:pulumi:Stack: (create)
    [urn=urn:pulumi:sandbox::cloudflared-tunnels::pulumi:pulumi:Stack::cloudflared-tunnels-sandbox]
    + components:tunnels:Tunnel: (create)
        [urn=urn:pulumi:sandbox::cloudflared-tunnels::components:tunnels:Tunnel::gb-lon-li-cfdtunnel]
    + components:tunnels:Tunnel: (create)
        [urn=urn:pulumi:sandbox::cloudflared-tunnels::components:tunnels:Tunnel::blease-test]
        + random:index/randomId:RandomId: (create)
            [urn=urn:pulumi:sandbox::cloudflared-tunnels::components:tunnels:Tunnel$random:index/randomId:RandomId::blease-test-argoSecret]
            [provider=urn:pulumi:sandbox::cloudflared-tunnels::pulumi:providers:random::default_4_13_2::04da6b54-80e4-46f7-96ec-b56ff0331ba9]
            byteLength: 35
        + random:index/randomId:RandomId: (create)
            [urn=urn:pulumi:sandbox::cloudflared-tunnels::components:tunnels:Tunnel$random:index/randomId:RandomId::gb-lon-li-cfdtunnel-argoSecret]
            [provider=urn:pulumi:sandbox::cloudflared-tunnels::pulumi:providers:random::default_4_13_2::04da6b54-80e4-46f7-96ec-b56ff0331ba9]
            byteLength: 35
        + cloudflare:index/tunnel:Tunnel: (create)
            [urn=urn:pulumi:sandbox::cloudflared-tunnels::components:tunnels:Tunnel$cloudflare:index/tunnel:Tunnel::gb-lon-li-cfdtunnel-tunnel]
            [provider=urn:pulumi:sandbox::cloudflared-tunnels::pulumi:providers:cloudflare::default_5_4_1::04da6b54-80e4-46f7-96ec-b56ff0331ba9]
            accountId : "00991122"
            configSrc : "cloudflare"
            name      : "gb-lon-li-cfdtunnel"
            secret    : output<string>
        + cloudflare:index/tunnel:Tunnel: (create)
            [urn=urn:pulumi:sandbox::cloudflared-tunnels::components:tunnels:Tunnel$cloudflare:index/tunnel:Tunnel::blease-test-tunnel]
            [provider=urn:pulumi:sandbox::cloudflared-tunnels::pulumi:providers:cloudflare::default_5_4_1::04da6b54-80e4-46f7-96ec-b56ff0331ba9]
            accountId : "00991122"
            configSrc : "cloudflare"
            name      : "blease-test"
            secret    : output<string>
    + components:tunnels:TunnelConfig: (create)
        [urn=urn:pulumi:sandbox::cloudflared-tunnels::components:tunnels:TunnelConfig::gb-lon-li-cfdtunnel]
        cloudflareAccountId: "00991122"
        cloudflareTunnelId : output<string>
        cloudflareZone     : "<http://foobar.com|foobar.com>"
        tunnelServices     : {
            my-app: "<http://myapp.com>"
        }
    + components:tunnels:TunnelRoute: (create)
        [urn=urn:pulumi:sandbox::cloudflared-tunnels::components:tunnels:TunnelRoute::blease-test]
        cloudflareAccountId: "00991122"
        cloudflareTunnelId : output<string>
        privateNetworks    : [
            [0]: "192.168.1.0/24"
        ]
        + cloudflare:index/tunnelRoute:TunnelRoute: (create)
            [urn=urn:pulumi:sandbox::cloudflared-tunnels::components:tunnels:TunnelRoute$cloudflare:index/tunnelRoute:TunnelRoute::blease-test-route-192.168.1.0/24]
            [provider=urn:pulumi:sandbox::cloudflared-tunnels::pulumi:providers:cloudflare::default_5_4_1::04da6b54-80e4-46f7-96ec-b56ff0331ba9]
            accountId : "00991122"
            network   : "192.168.1.0/24"
            tunnelId  : output<string>
        + cloudflare:index/tunnelConfig:TunnelConfig: (create)
            [urn=urn:pulumi:sandbox::cloudflared-tunnels::components:tunnels:TunnelConfig$cloudflare:index/tunnelConfig:TunnelConfig::gb-lon-li-cfdtunnel-tunnel-config]
            [provider=urn:pulumi:sandbox::cloudflared-tunnels::pulumi:providers:cloudflare::default_5_4_1::04da6b54-80e4-46f7-96ec-b56ff0331ba9]
            accountId : "00991122"
            config    : {
                ingressRules: [
                    [0]: {
                        hostname  : "<http://my-app.connect.com|my-app.connect.com>"
                        service   : "<http://myapp.com>"
                    }
                    [1]: {
                        service   : "http_status:404"
                    }
                ]
                warpRouting : {
                    enabled   : true
                }
            }
            tunnelId  : output<string>
2 Views