https://pulumi.com logo
#install
Title
# install
d

damp-football-45622

07/02/2023, 2:57 PM
Hi, i compiled pulumi from source every release but since around 10 weeks it does not work any more. I checkout the source switch to a release tag ---
Copy code
set the PATH=$HOME/.pulumi-dev:$HOME/go/bin:$PATH
make ensure 
make dist
than I get this:
Copy code
go install -ldflags "-X <http://github.com/pulumi/pulumi/sdk/v3/go/common/version.Version=3.74.0-dev.0|github.com/pulumi/pulumi/sdk/v3/go/common/version.Version=3.74.0-dev.0>" <http://github.com/pulumi/pulumi/sdk/go/pulumi-language-go/v3|github.com/pulumi/pulumi/sdk/go/pulumi-language-go/v3>
no required module provides package <http://github.com/pulumi/pulumi/sdk/go/pulumi-language-go/v3;|github.com/pulumi/pulumi/sdk/go/pulumi-language-go/v3;> to add it:
	go get <http://github.com/pulumi/pulumi/sdk/go/pulumi-language-go/v3|github.com/pulumi/pulumi/sdk/go/pulumi-language-go/v3>
make[1]: *** [Makefile:43: dist] Error 1
i tried to find the reason but i’m still not found anything to reenable the build. Do you have any idea how enable the build from source again. thx in advance
l

limited-rainbow-51650

07/03/2023, 7:58 AM
Hello @damp-football-45622, there was some rework to the build system, but this should be fixed now. https://github.com/pulumi/pulumi/issues/13335
d

damp-football-45622

07/03/2023, 8:00 AM
many thanks — so the better would be to use the goreleaser
oh the setup of the goreleaser is some kind of tricky
thx the make dist works now again
6 Views