https://pulumi.com logo
#aws
Title
# aws
r

rough-jordan-15935

07/26/2023, 12:50 PM
I deployed a lambda function with pulumi on AWS, and got this error - Here's my package json "@pulumi/pulumi": "^3.0.0", "@pulumi/aws": "^5.0.0", "@pulumi/awsx": "^1.0.0",
@fierce-ability-58936 do you have any inputs
the pulumi team hardly ever replies to any concerns
f

fierce-ability-58936

07/27/2023, 10:01 AM
Well, honestly, it's hard to answer this question without additional context. All right, let's debug this 🙂 I guess you're using Pulumi with either Javascript or Typescript. It can't find the module. I think it should be in the
node_modules
folder. Does the folder exist?
r

rough-jordan-15935

07/27/2023, 10:02 AM
i fixed it 🙂 downgrading pulumi versions helped
f

fierce-ability-58936

07/27/2023, 10:09 AM
Ah, I bet upgrading the Pulumi SDK would help as well!
l

limited-rainbow-51650

08/02/2023, 2:27 PM
@rough-jordan-15935 sorry for the late reply, but I was on PTO for the past two weeks. Regarding the version of the Pulumi CLI and
@pulumi/pulumi
, we advice to keep to versions of both close enough to each other. The don't need to be the exact same versions though. Your
package.json
file contains
^3.0.0
, but your
package-lock.json
or
yarn.lock
file contains the actual version in use. Try to update these dependencies on a regular basis.
r

rough-jordan-15935

08/04/2023, 6:18 AM
hey @limited-rainbow-51650 sure. will look into this. this however happened even after creating a new project with pulumi new, used the serverless api template for aws. and after a few deployments, one random deployment caused this error too