https://pulumi.com logo
#general
Title
# general
t

tall-beard-99429

07/31/2023, 2:05 PM
Hi, i'm getting a
409
error about another update in progress, or was previously interrupted. However, when I run
pulumi cancel
I get
error: [409] Conflict: The Update has already completed
. So i appear to be in a completely broken state. I've checked the stack export and there is nothing in there that's a problem. Any ideas how I can resolve this?
It appears that doing a
pulumi refresh
fixed this. It showed 0 changes to be made, but when I ran it, I was able to then run
update
as expected.
e

echoing-dinner-19531

07/31/2023, 3:34 PM
It might have been the lease timed out between the first error and you running cancel.
t

tall-beard-99429

07/31/2023, 3:35 PM
I ran them both multiple times and it continually happened over ~ 10 minutes of testing and debugging
Immediately after
refresh
it resolved itself
e

echoing-dinner-19531

07/31/2023, 3:35 PM
That does sound like a bug in the service then
t

tall-beard-99429

07/31/2023, 3:35 PM
The two errors I got were:
Copy code
This will irreversibly cancel the currently running update for 'main'!
Please confirm that this is what you'd like to do by typing `main`: main
error: [409] Conflict: The Update has already completed
and
Copy code
error: [409] another update is currently in progress or was interrupted. Try again later.) Try again later
    for more information about this error, see <https://pulumi.io/oa5g1o>
To learn more about possible reasons and resolution, visit <https://www.pulumi.com/docs/troubleshooting/#conflict>
e

echoing-dinner-19531

07/31/2023, 3:36 PM
Can you raise an issue for this at https://github.com/pulumi/pulumi-cloud-requests I don't really have any access to internal service data so not something I can further help with.
t

tall-beard-99429

07/31/2023, 3:36 PM
Sure
I assume its safe to post the link above?
e

echoing-dinner-19531

07/31/2023, 3:39 PM
Yeh, it's all access controlled the most anyone will get from that being public is your account name.
t

tall-beard-99429

07/31/2023, 3:39 PM
Great, thanks
3 Views