https://pulumi.com logo
#general
Title
# general
m

mammoth-address-35860

08/08/2023, 11:54 AM
Hello, I've been using pulumi for 4 months now, and just got the news that the awsx library is now deprecated. I'm just starting to move away from it, but most of the examples and documentation around pulumi are heavily dependant on awsx. Is there any updated documentation that doesn't involve awsx? 🙂
b

billowy-army-68599

08/08/2023, 12:29 PM
awsx is not deprecated. the awsx version less thann 1.0 is deprecated, you just need to upgrade
m

mammoth-address-35860

08/08/2023, 12:32 PM
I'm sorry, but the Pulumi AI itself is stating that awsx is deprecated:
b

billowy-army-68599

08/08/2023, 12:40 PM
Pulumi AI is not giving you correct information in this case. awsx is not deprecated
is this the only place you got this news? I will file a bug with AI to make sure it doesn’t hallucinate this information
m

mammoth-address-35860

08/08/2023, 12:52 PM
Oh, I'm really happy to hear that! It was one of my colleagues that brought this issue to me - then I went to your AI to confirm, and always got the same answer when asking: "awsx is deprecated"... So, can we safely rely on it? No need to go through the painful process of adopting resources?
r

rough-morning-53309

08/08/2023, 1:04 PM
As the product manager overseeing AWSx, I can confirm that it is not deprecated. We are aware of this recommendation from Pulumi AI and have an internal issue tracking resolution. We are actively engaged on on improving the results and experience here. Thank you for sharing here! 👍
2 Views