https://pulumi.com logo
#aws
Title
# aws
b

better-lighter-76945

08/09/2023, 7:13 PM
Hi! I randomly started getting an error when deploying my lambda,
Copy code
error: aws:lambda/function:Function resource 'spotify-sync' has a problem: expected runtime to be one of [nodejs nodejs4.3 nodejs6.10 nodejs8.10 nodejs10.x nodejs12.x nodejs14.x java8 java8.al2 java11 python2.7 python3.6 python3.7 python3.8 python3.9 dotnetcore1.0 dotnetcore2.0 dotnetcore2.1 dotnetcore3.1 nodejs4.3-edge go1.x ruby2.5 ruby2.7 provided provided.al2], got nodejs18.x. Examine values at 'Function.Runtime'.
It was working fine up until right now, I literally have a lambda deployed in AWS right now with this runtime (pic attached). I am on the most recent pulumi version
Copy code
"@pulumi/aws": "^5.0.0",
    "@pulumi/pulumi": "^3.0.0",
and here is my lamba definition:
Copy code
const SpotifySyncLambda = new aws.lambda.Function('spotify-sync', {
  code: new pulumi.asset.AssetArchive({
    '.': new pulumi.asset.FileArchive(APP_DIR),
  }),
  environment: {
    variables: GLOBAL_LAMBDA_VARS,
  },
  handler: 'index.SpotifySyncHandler',
  runtime: 'nodejs18.x',
  role: SPOTIFY_SYNC_ROLE.arn,
});
does anyone know what could be wrong, or why pulumi is suddenly enforcing such an outdated nodejs runtime?
i ran
pulumi about
and got a warning about my package lock file not being found. adding this file back fixed the issue. thx!