Hi all, I'm trying to use the docker provider on l...
# general
g
Hi all, I'm trying to use the docker provider on linux and getting the following error: "Error pinging Docker server: Cannot connect to the Docker daemon at unix:///home/ian/.docker/run/docker.sock. Is the docker daemon running?" I checked the docker endpoint for docker desktop using
docker context ls
and found that my endpoint is unix:///home/ian/.docker/desktop/docker.sock. This is the same as the default endpoint listed on this page, which the provider documentation links to. Does anybody know how to change the default endpoint, either for the docker context or for the docker provider? What am I doing wrong? I'm using python on linux mint vera if that matters.
I have tried setting the DOCKER_HOST environment variable to my endpoint and I have tried using
docker context create
to create a new context with the endpoint pulumi is expecting
s
Would you mind opening an issue in https://github.com/pulumi/pulumi-docker/ ? This behavior seems unexpected. You’re using the default context, correct? (The Pulumi Docker provider had issues with contexts last time I checked.)
g
Yes I am using the default context
s
I had to ask. 🙂 If you don’t mind, please open an issue.
g
Thanks for the quick reply! I figured I'd check here first just in case I'm missing something obvious