https://pulumi.com logo
#typescript
Title
# typescript
b

brave-alarm-22747

09/11/2023, 6:51 PM
Hi friends, have you experienced this problem? I am creating a horizontalPodAutoscaler on a gcp cluster running k8s 1.24 version, the apiVersion supposed to be v2 according to the pulumi annotations, but as you can see, it is being created with v2beta2 version, do you know why?
Copy code
apiVersion: autoscaling/v2beta2
kind: HorizontalPodAutoscaler
metadata:
  annotations:
    <http://kubectl.kubernetes.io/last-applied-configuration|kubectl.kubernetes.io/last-applied-configuration>: >
      {"apiVersion":"autoscaling/v2","kind":"HorizontalPodAutoscaler","metadata":{"annotations":{"<http://pulumi.com/autonamed|pulumi.com/autonamed>":"true"}
I am creating it using
kubernetes.autoscaling.v2.HorizontalPodAutoscaler
from pulumi my packages are the following versions
Copy code
"@pulumi/gcp": "^6.65.0",
        "@pulumi/kubernetes": "^4.1.1",
        "@pulumi/pulumi": "^3.81.0",