https://pulumi.com logo
#pulumi-deployments
Title
# pulumi-deployments
p

polite-ocean-13631

09/18/2023, 5:43 PM
I'm trying to set up Pulumi Deployments, but for some reason deployment previews are no longer being run. They were previously running in the PR I was editing, which has changed files under the
infra
directory. The path filter is set to
infra/**
. I know it has access to GitHub since it was previously accessing it. I'm not sure what changed that made it stop running the deployment previews.
It looks like the deployment previews are running in Pulumi Cloud, but not being reported back to GitHub via the GitHub App
This might be because it's erroring during setup, when it attempts to pull the image
Copy code
1
 Preparing environment 
2
 Pulling container image "<http://ghcr.io/meltano/pulumi:latest|ghcr.io/meltano/pulumi:latest>" 
3
 image pull failed; retrying 
4
 Pulling container image "<http://ghcr.io/meltano/pulumi:latest|ghcr.io/meltano/pulumi:latest>" 
5
 image pull failed; retrying 
6
 Pulling container image "<http://ghcr.io/meltano/pulumi:latest|ghcr.io/meltano/pulumi:latest>" 
7
 image pull failed; retrying 
8
 Pulling container image "<http://ghcr.io/meltano/pulumi:latest|ghcr.io/meltano/pulumi:latest>" 
9
 image pull failed; retrying 
10
 Pulling container image "<http://ghcr.io/meltano/pulumi:latest|ghcr.io/meltano/pulumi:latest>" 
11
 giving up 
12
 pulling image: retry limit reached
@microscopic-florist-22719 Do you know why this might be failing? The registry is the GitHub registry, ghcr.io, the repository username is a GitHub username, and the repository password is a GitHub PAT with read permission for packages. I've tested out these credentials locally by logging in via
docker login
then pulling the image, and it worked fine.
The image is only available for
linux/amd64
- could that be the problem?
l

lemon-agent-27707

09/19/2023, 12:16 AM
@polite-ocean-13631 you may have seen the status page update, there is a wide spread AWS outage related to ec2 and networking that is impacting Deployments and anything networking related that happens within the runs (downloading dependencies, source code, etc).
p

polite-ocean-13631

09/19/2023, 8:27 PM
@lemon-agent-27707 I see the status has been updated to "All Systems Operational", but I'm not seeing any deployments being made, or comments being left by the GitHub app
l

lemon-agent-27707

09/19/2023, 8:35 PM
Are you able to click to deploy to initiate a preview on the stack? Just want to isolate the issue.
There are some other things that could prevent a PR preview from running: • an incorrectly configured path filter • if the PR was opened by a github org member who membership is set to
private
p

polite-ocean-13631

09/19/2023, 8:37 PM
fyi I'm working through this in a DM with @witty-candle-66007
We had already ruled out the path filter problem (by removing the path filters), and the GitHub org member problem (by using an org member who had used Pulumi Deployments yesterday without issue)
I was able to do a manual deployment, but the automatic ones didn't work. Changes to the tracked branch in GitHub do nothing. Nothing shows up in the "Activity" tab
Mitch suggested disabling the custom image, and it caused it to run automatically when the next commit was pushed to the tracked branch
Then I re-enabled the custom image, and it worked again automatically
So maybe there's a bug where it requires at least one run to occur without a custom image before a custom image can be used?
l

lemon-agent-27707

09/19/2023, 8:42 PM
Hm, that does sound strange. If you have a repro, would you mind opening a bug so we can investigate? https://github.com/pulumi/pulumi-cloud-requests/issues/new/choose
w

witty-candle-66007

09/19/2023, 8:43 PM
I’ll put together a repro and open an issue.