when managing deployment settings with the `pulumi...
# pulumi-deployments
when managing deployment settings with the
provider, i find that the changes aren't really "finalized" by the provider -- i have to go in to the console, make no changes, and click "Save deployment configuration." all of the settings are fully populated by the provider, so it certainly appears to have worked, but it doesn't work until I click that save button. has anyone else run into this? Is there a step i'm missing?
this sounds like a bug, could you open an issue?
sure thing
This is definitely unexpected. When you say it hasn’t worked what exactly do you mean?
at a minimum, it doesn't properly interact with github -- it doesn't trigger on new PRs, for instance. i'm working to recreate the situation (without interrupting our existing workflow) so i can see if manually triggered deployments function as expected
but it's possible that the only setting that isn't really getting applied is "Run previews for pull requests"
that's a helpful lead, thank you. let me take a look
hm, nothing obviously stands out from a quick look. would appreciate a repro if you can get one!
okay, a few more details: i've just enabled deployments for a stack for the first time. the deployment settings page in the console is entirely populated, but all of the stuff in the "Actions" is grayed out if i try to use it as a non-admin user:
however, i can manually trigger a deployment just fine as an admin user, and after doing so, suddenly the non-admin user can access all of that functionality too
i.e., those things are no longer grayed out as non-admin once an admin runs a preview
i'm guessing the manually-triggered preview has the same effect as the no-op save
that may have been a fluke, i couldn't reproduce that on two other stacks that i just enabled 😕
Hey Chris, sorry you're having trouble here. Can you share with us the code for deployment settings via the pulumi provider? One thing to note is that you have to use the full branch name. The deployment settings UI hides this, but it actually expands the full value:
Copy code
sourceContext: {
            git: {
                branch: "refs/heads/main",
If you only supply
then pull request events will not work.
i bet that's it
when i click "save" it appears that no changes were made, but a secret change was made behind the scenes
Yes apologies. We have a bug open internally to fix that and accept short branch names in addition to the fully qualified ones.
Can you confirm that specifying the full branch fixes the issue you were seeing?
confirmed, that fixed it