https://pulumi.com logo
#golang
Title
# golang
p

proud-alligator-5865

11/30/2023, 11:51 AM
Hi! I'm trying to set up Pulumi to create a Postgres database server in azure. After a few trial and errors I have now reached a problem, and I was wondering if anyone had a solution. When creating the PostgreSQL server, the error says: > Resource was disallowed by policy. Reasons: 'Public network access must be disabled for PaaS Services. I can't find any
PublicNetworkAccess
field in the
FlexibleServerArgs
struct that I'm using below, so I wanted to ask: what should I do in that scenario?
Copy code
serverArgs := &postgresql.FlexibleServerArgs{
			ResourceGroupName:     resourceGroup.Name,
			Location:              resourceGroup.Location,
			Version:               pulumi.String("12"),
			AdministratorLogin:    pulumi.String(adminUser),
			AdministratorPassword: conf.RequireSecret("databasePassword"),
			StorageMb:             pulumi.Int(32768),
			SkuName:               pulumi.String("GP_Standard_D4s_v3"),
			Zone:                  pulumi.String("1"),
		}

		server, err := postgresql.NewFlexibleServer(ctx, serverName, serverArgs)
		if err != nil {
			return err
		}
e

elegant-window-55250

11/30/2023, 12:00 PM
Postgresql is a Azure resource?
Have you tried using
<https://www.pulumi.com/registry/packages/azure/api-docs/postgresql/server/#publicnetworkaccessenabled_go|PublicNetworkAccessEnabled>
and set that to
false
?
2 Views