https://pulumi.com logo
#python
Title
# python
r

rhythmic-arm-71682

03/04/2024, 4:22 PM
I'm having some issues getting my Python virtual environment (or just the python in the OS, itself) to recognize pulumi_awsx and pulumi_eks. I've installed both through pip and doing a 'pip list' shows pulumi_awsx = 2.5.0 and pulumi_eks = 2.2.1 Yet, while importing and running the modules doing a 'pulumi up', I get an error saying ModuleNotFoundError: No module named 'pulumi_eks'. Anyone else have this issue?
h

hundreds-gpu-71155

03/04/2024, 4:25 PM
are you sure you used venv's pip instead of some global pip?
is the venv activated when you run pulumi?
r

rhythmic-arm-71682

03/04/2024, 6:40 PM
I believe I installed both pulumi_eks and pulumi_awsx before I created and activate the venv. I've also installed inside the venv as well. Yes, the venv is activated when I run pulumi
Looks like I have my issue fixed. My pulumi.yaml points to 'venv'. My 'venv' did not have pulumi_eks installed. I had a couple other virtual environments in that folder that I ran on that did. I renamed one of those environments to venv as the pulumi.yaml has listed and removed all other environments. Now I can see it.