I'm having trouble with pulumi thinking I'm in non...
# esc
I'm having trouble with pulumi thinking I'm in non-interactive mode when using
esc run
Copy code
$ esc run dara -- pulumi up
error: --yes or --skip-preview must be passed in to proceed when running in non-interactive mode
Error: exit status 255
Any ideas? I've already tried
PULUMI_DISABLE_CI_DETECTION=true esc run dara -- pulumi up
This has the same result. This is running on my local machine, and I've double-checked that my environment variables don't contain any of the detectable variables here: https://github.com/pulumi/pulumi/blob/master/sdk/go/common/util/ciutil/detect.go#L147 I've also added
to my esc environment variables and no joy.
Also of note: I'm using
GNU bash, version 5.2.15(1)-release (x86_64-pc-linux-gnu)
and if I don't use
esc run
it detects interactive mode correctly
Maybe unrelated, but you shouldn't need to pass in
esc run ...
if your environment is listed in the stack config
You can just run
pulumi up
Also, to run interactively using
esc run ...
you'll need to pass
ohhh nice
well that definitely solved it!
Thanks @red-match-15116!
@red-match-15116 BTW, my entire startup is absolutely THRILLED by pulumi! You're all doing amazing work, and it's saved us over a month of development time.
If there's anything we can do for you in terms of a case study or testimonial, point me in the right direction!
Thanks so much Dara! We love to hear that 🙂 I'll pass along your message internally, I'm sure we'd love to do a case study
@elegant-oyster-42272 nice to meet you. i'll DM you to chat more about a case study