has anybody encountered this issue before, where t...
# aws
has anybody encountered this issue before, where there is a clear diff in your code... but
pulumi up -r
still says at the end that your resources are unchanged? What's even more puzzling as well is the difference between the summary I see at the command line.. vs what I see at app.pulumi.com (For the record, I basically removed the
argument for my security groups, and I was expecting that Pulumi would detect the change and apply it)
pulumi up -r
command currently presents the results of the refresh part and the up part overlapping and intertwined a bit, which can make things a little harder to interpret. We now we need to make some improvements here. That said - to understand whether the issue you are running into is about that presentation, vs a deeper issue. It would be useful to understand whether you see what you expect if you decouple these two actions and run: •
pulumi refresh
Pulumi up
Do you see the right thing from both commands in that case?
I just tried with
pulumi up
(with no refresh): nope, still unchanged! Not just unchanged in terms of the preview, but totally unchanged after application as well. For the record, what I did was I had my security groups with both ingress and egress rules inline... And then I reworked my network config so that I dont need the egress rules anymore in the security group. So the diff is basically me removing the egress rules from the security groups.
tried with
egress = None
as well, just in case... but that does not work as well, and no changes happen for the security groups