https://pulumi.com logo
Title
f

freezing-yacht-63937

07/27/2022, 11:21 AM
Hello, when i deploy traefikv2 helm chart the service namespace is set to default even though i set
namespace: traefikNamespace.metadata.name,
and
transformations: [
    (obj: any, opts: pulumi.CustomResourceOptions) => { 
        if (obj.kind === "Service") {
            obj.metadata.namespace == traefikNamespace.metadata.name
        }
    }
],
But work when i set
kubectl config set-context --current --namespace=NAMESPACE
Should i create an own k8s provider with correct namespace, or I am doing something wrong?
s

steep-toddler-94095

07/27/2022, 4:33 PM
IIRC Pulumi has a bug with the namespace property in the Helm resource. I would guess the traefik helm chart has a Values parameter that allows you to specify the namespace. Could you try that instead?
❤️ 1
f

freezing-yacht-63937

07/28/2022, 6:42 AM
unfortunately it dosent have that value parameter, i can use the workaround in the mean time, thx for the help 🙂