Hello everyone! I am trying to login into a S3 co...
# general
e
Hello everyone! I am trying to login into a S3 compatible backend ( Dell ECS 3.6.2). I have received: • bucket url • bucket name • username • secret Which must be sufficient to integrate pulumi with the S3 backend. I have tried different scenarious. Has anyone tips, hints how to tackle this issue? My general idea was as stated in the documentation to do something like:
Copy code
pulumi login 's3://<bucket-name>?endpoint=my.minio.local:8080&disableSSL=true&s3ForcePathStyle=true'
m
What exactly is the problem you're facing?
l
try with region=local
pulumi login 's3://<bucket-name>?region=local&endpoint=my.minio.local:8080&disableSSL=true&s3ForcePathStyle=true'
I assume that AWS_SECRET_ACCESS_KEY and AWS_ACCESS_KEY_ID are set
e
I am unfortunately totally new to S3 in general! Where I need to set the username and the secret I received? I need to set these as environment variables as you mentioned @limited-wire-44163? I have set
export AWS_ACCESS_KEY_ID=myuser
export AWS_ACCESS_KEY=myplainpassword
When I try
pulumi login 's3://<bucket-name>?region=local&endpoint=my.minio.local:8080&disableSSL=true&s3ForcePathStyle=true'
Copy code
error: problem logging in: read ".pulumi/meta.yaml": blob (key ".pulumi/meta.yaml") (code=Unknown): NoCredentialProviders: no valid providers in chain. Deprecated.
        For verbose messaging see aws.Config.CredentialsChainVerboseErrors

Apparently I could login with setting these parameters!

Will update the thread if not
m
Are you using MinIO? In this case, the region is always us-east-1, which you can set by
export AWS_REGION=us-east-1
Once you've configured the AWS credentials, you should be able to interact with your S3-compatible storage via the AWS CLI, e.g.,
aws --endpoint-url <http://localhost:9000> s3 ls s3://<bucket name>
e
I added AWS_ACCESS_KEY_ID and AWS_SECRET_ACCESS_KEY and can leverage pulumi preview/up to provide the desired resources via the s3 compatible storage . I am not using MinIo but I am using Dell ECS 3.6.2 (provided from the storage team) However I set as region "local" which seem to work for me. That was @limited-wire-44163 mentioned in this thread