a

    ambitious-father-68746

    1 month ago
    Hi, after upgrading to pulumi-aws 5.11.0 I'm getting an error everytime I specify resource options on a resource. This works:
    aws.get_availability_zones()
    This breaks:
    aws.get_availability_zones(
        opts=pulumi.ResourceOptions(),
    )
    The error is:
    File "/tmp/tmp.T1ec9S84a7/pulumi/venv/lib64/python3.10/site-packages/pulumi_aws/get_availability_zones.py", line 202, in get_availability_zones
            opts = pulumi.InvokeOptions.merge(_utilities.get_invoke_opts_defaults(), opts)
          File "/tmp/tmp.T1ec9S84a7/pulumi/venv/lib64/python3.10/site-packages/pulumi/invoke.py", line 115, in merge
            raise TypeError("Expected opts2 to be a InvokeOptions instance")
        TypeError: Expected opts2 to be a InvokeOptions instance
    Anyone else seeing the same thing? 5.10.0 works fine.