Thread
#general
    p

    purple-plastic-64657

    1 month ago
    How do I install a previous version of pulumi on a mac. I did a brew upgrade to 3.38.0. It is not working correctly
    s

    stocky-restaurant-98004

    1 month ago
    Unfortunately, while it's incredibly convenient for the latest version, Homebrew makes installing previous versions of a package difficult. I'd try the instructions here: https://www.pulumi.com/docs/get-started/install/#installing-betas-and-previous-versions Can you provide more info about the issue you're facing in 3.38.0?
    p

    purple-plastic-64657

    1 month ago
    It fails adding a security group to a lambda function that needs access to a VPC
    Diagnostics:
      pulumi:pulumi:Stack (lambdas-python-sgtest):
        error: update failed
    
      aws:lambda:Function (middleware-sgtest-WellsFargo):
        error: 1 error occurred:
        	* error creating Lambda Function (1): InvalidParameterValueException: Error occurred while DescribeSecurityGroups. EC2 Error Code: InvalidGroup.NotFound. EC2 Error Message: The security group 'sg-xxxxxxxxx' does not exist
        {
          RespMetadata: {
            StatusCode: 400,
            RequestID: "7f06c6f0-f439-4771-a660-f7c5ad964d11"
          },
          Message_: "Error occurred while DescribeSecurityGroups. EC2 Error Code: InvalidGroup.NotFound. EC2 Error Message: The security group 'sg-xxxxxxxxxxx' does not exist",
          Type: "User"
        }
    s

    stocky-restaurant-98004

    1 month ago
    I don't think that's an issue due to Pulumi CLI. That error is coming from the AWS API most likely.
    p

    purple-plastic-64657

    1 month ago
    It doesn't occur for a colleague running an earlier version of the pulumi cli
    What is the highest aws cli version supported?
    s

    stocky-restaurant-98004

    1 month ago
    Are you sure you're both hitting the same AWS account with the same permission levels in the same region?
    (different regions is the most likely culprit)
    p

    purple-plastic-64657

    1 month ago
    Now that I've uninstalled pulumi, I see that I rebuilt this project from scratch and managed to get one of the config params wrong. There are two aws region values and was only prompted for one of them for the stack config. The other got a default which is different and incorrect.
    That was it thanks for your help!
    s

    stocky-restaurant-98004

    1 month ago
    You're most welcome! Pretty common mistake - I make it myself still after using AWS for like 5 years.