https://pulumi.com logo
#azure
Title
# azure
f

fast-vr-6049

08/29/2022, 5:19 PM
Hey folks! I'm curious if anyone else has run into this issue. I'm trying to import some manually created resources into my stack: an Azure virtual network gateway, local network gateway, and connection config for a VPN setup. However, when I try to import them (or indeed anything at all), the CLI throws an error from the Azure API:
Copy code
azure-native:network:V20201101:subnet (GatewaySubnet):
    error: Preview failed: autorest/azure: Service returned an error. Status=400 Code="MissingApiVersionParameter" Message="The api-version query parameter (?api-version=) is required for all requests."
It looks like the Azure Native plugin for
pulumi.exe
isn't passing along the API version parameter, and I can't for the life of me figure out if I can provide that myself. I've tried supplying a provider version when giving the import command, but that hasn't worked. The Azure CLI doesn't seem to accept an environment variable to append such a value to all requests, either. Am I missing something, or is this a bug?
61 Views