# general


08/31/2022, 6:47 PM
Hey Pulumi, v6.36.0 of the pulumi-gcp plugin breaks all my deployments, specifically in the automation-api. The reason is the first item in the changelog: link to PR It breaks even in the refresh step, saying for all resources:
Copy code
gcp:pubsub:SubscriptionIAMMember <resource-name> refreshing error: unable to find required configuration setting: GCP Project
To fix this I attempted to set the gcp:project setting globally for the stack by issuing
Copy code
if err := s.SetAllConfig(ctx, map[string]auto.ConfigValue{
		"gcp:project": {Value: p.Project},
		"gcp:region":  {Value: p.GcpRegion},
	}); err != nil {
		return nil, errors.Wrap(err, "failed to set config")
But that did not resolve the issue either.
As a workaround I downgraded back to v6.35.0 which resolved all problems.
I don’t have the time to write a proper issue right now, but wanted to bring it to your attention nonetheless.
The issue also occurred outside the automation API in the interactive Pulumi project I have. I do not only deploy to one project, so I used a nonstandard parameter
Copy code
gcp-cfg:project: <project-name>
instead of
Copy code
gcp:project: <project-name>
Using this nonstandard parameter I set the project for each resource. This does not work anymore with v6.36.0, where the default config key
needs to be set or not even a refresh will work.


08/31/2022, 7:27 PM
I've pinged the team responsible for gcp so they see this
🙏 1


08/31/2022, 7:28 PM
could you file an issue @steep-island-39848 so we can track this


08/31/2022, 8:04 PM
hello @steep-island-39848 please add details to this issue when you get a chance:


09/01/2022, 7:36 AM
@shy-arm-32391 I added a comment in GitHub. It’s not as bad as it looked when I upgraded and nothing worked anymore, but it is a breaking change so maybe a warning in the release notes / changelog would be enough to point people in the right direction.


09/01/2022, 10:30 AM
@steep-island-39848 Could this issue be responsible for this error? error:
Copy code
gcp:iam:WorkloadIdentityPoolProvider (gcp-workload-identity-provider-dwh-github-actions-wipp):
    error: 1 error occurred:
        * updating urn:pulumi:dwh::gcp-workload-identity-provider::gcp:iam/workloadIdentityPoolProvider:WorkloadIdentityPoolProvider::gcp-workload-identity-provider-dwh-github-actions-wipp: 1 error occurred:
        * Error updating WorkloadIdentityPoolProvider "projects/stately-lodge-257509/locations/global/workloadIdentityPools/github/providers/dwh-analytics": Patch "<>": dial tcp: lookup <|> on no such host
PS. I do not quite understand the Go snippet you added and how does it help, I'm not using automation api


09/01/2022, 10:59 AM
@great-sunset-355 as far as I can tell this should not be the same issue
The Go snippet only resolves the error
unable to find required configuration setting: GCP Project
that popped up in my case, and specifically for the automation API, not regular use of Pulumi
Your issue looks like it might actually just be intermittent, maybe a DNS issue, but obviously I can be wrong here
I hope you find a solution soon! 🤞


09/01/2022, 11:09 AM
DNS issue is only problem with pulumi, traceroute and nslookup work perfectly fine. I downgraded all the way down to 6.32.0 where stuff worked and it still wokrs
so I suspect it to be related somehow
IMO provider seems to be confused how to even contact GCP... I did not run TF_LOG=DEBUG yet (no time)