https://pulumi.com logo
#google-cloud
Title
# google-cloud
d

damp-elephant-82829

09/01/2020, 7:49 AM
Hey guys, I think I have hit an infinite recursion problem, activating the service usage API fails with pulumi because… well because the service usage API has not been activated yet! cpprojectsService (EnableServiceUsage): gcpprojectsService (EnableServiceUsage): Step #9 - “Pulumi Create Stack”: error: Error when reading or editing Project Service : Request “List Project Services my-project” returned error: Failed to list enabled services for project my-project: googleapi: Error 403: Service Usage API has not been used in project XYZ before or it is disabled. Enable it by visiting XYZ then retry. If you enabled this API recently, wait a few minutes for the action to propagate to our systems and retry., accessNotConfigured
w

worried-rainbow-92557

09/01/2020, 10:09 AM
Any code to share? How was the GCP project created?
d

damp-elephant-82829

09/01/2020, 10:10 AM
via Pulumi
It is the only thing that doesn’t work for me. Let me recap: • I create an ephemeral project • I create a service account • I make it a project owner • I create a service account key • I create a new provider for GCP and I use to create the subsequent resources
w

worried-rainbow-92557

09/01/2020, 11:50 AM
Hard to tell without seeing the code what could be wrong. The Service Usage API should be enabled by default with new projects. Is it just the project hasn’t finished initialising?
6 Views