https://pulumi.com logo
Title
e

eager-thailand-33661

06/24/2021, 10:10 AM
Hi, anyone tried gcp-native with Python? I get errors telling me that the semver has illegal characters when trying to install either as dependency in requirements.txt or by simply running the pulumi plugin install command.
b

brave-planet-10645

06/24/2021, 10:27 AM
What's the name of the package you're installing? It should be
pulumi-google-native
or if you're installing the plugin,
pulumi plugin install resource google-native
e

eager-thailand-33661

06/24/2021, 7:39 PM
thanks @brave-planet-10645 my bad 🤦‍♂️, I somehow ended up in a completely different pypi project "pulumi-gcp-native" and that one apparently had a version 0.0.2a1617829075 that didn't play well. https://pypi.org/project/pulumi-gcp-native/
b

brave-planet-10645

06/24/2021, 7:57 PM
So originally we did call it
pulumi-gcp-native
but to be more in line with what Google call their platform we renamed it. I'll talk to our engineers because that may cause others to have the same issue
👍 1
🙏 1