https://pulumi.com logo
#google-cloud
Title
# google-cloud
f

fast-arm-63150

11/08/2021, 10:02 PM
@prehistoric-activity-61023 just continuing off the last thread - I am, too, having issues with first activating/enabling services using the python automation SDK
p

prehistoric-activity-61023

11/08/2021, 11:21 PM
I haven’t used automation SDK yet but (assuming it’s similar to “standard pulumi”), make sure that you explicitly add
depends_on
attribute to dependent resources (this dependency cannot be discovered implicitly by pulumi).
That’s the first thing I can advice without knowing any more details about your case.
I am able to successfully enable required APIs and create a VPC in a freshly created GCP project so it’s doable 🙂. Unless, you’ve got some corner-case situation as Alex above.
Provide some more info what you’re trying to do and I’ll try to get back to it later.
f

fast-arm-63150

11/08/2021, 11:45 PM
@prehistoric-activity-61023 what did you make it "depends_on"?
@prehistoric-activity-61023 on an initial run of an inline pulumi program, I get this error when trying to enable/activate services
p

prehistoric-activity-61023

11/09/2021, 7:31 AM
can you paste the snippets how you: • create the given Secret in secretmanager • activate the secretmanager API?
Copy code
# activate Google API
	secret_manager_api = gcp.projects.Service(
	  "secret-manager-api",
	  service="<http://secretmanager.googleapis.com|secretmanager.googleapis.com>",
	)

	...

	# create Secret
	secret = gcp.secretmanager.Secret(
	  ...
	  opts=pulumi.ResourceOptions(
=>	    depends_on=[secret_manager_api]
	  ),
	)
you should create something more or less like the above
f

fast-arm-63150

12/27/2021, 6:30 PM
@prehistoric-activity-61023 hey thanks for the above, had to work on another project but back on this again