https://pulumi.com logo
#google-cloud
Title
# google-cloud
c

curved-summer-41191

01/06/2022, 4:10 PM
Is there an issue installing the GCP plugin on M1?
Copy code
❯ pulumi plugin install resource gcp v3.25.0
[resource plugin gcp-3.25.0] installing
error: [resource plugin gcp-3.25.0] downloading from : 403 HTTP error fetching plugin from <https://get.pulumi.com/releases/plugins/pulumi-resource-gcp-v3.25.0-darwin-arm64.tar.gz>
b

billowy-army-68599

01/06/2022, 4:12 PM
@curved-summer-41191 that's a really old version of the gcp provider, we only started releasing arm builds at 4.4.0 https://github.com/pulumi/pulumi-gcp/blob/master/CHANGELOG.md#4140-2021-03-15
is there a reason you're on that old version?
c

curved-summer-41191

01/06/2022, 4:12 PM
we just haven't spent the time to update all of our projects yet 😢
b

billowy-army-68599

01/06/2022, 4:13 PM
unfortunately you'll need to bump to at least 4.4.0 to use the arm binary 😞
c

curved-summer-41191

01/06/2022, 4:14 PM
no worries, I'll give it a go - thanks for confirming that was my issue!
@billowy-army-68599 I updated to a new version but I'm still getting the error for that version of the plugin Here's the start of the GCP block in my package-lock (typescript)
Copy code
"node_modules/@pulumi/gcp": {
      "version": "5.26.0",
Is there somewhere else this plugin version gets decided or cached?
b

billowy-army-68599

01/06/2022, 4:20 PM
The old version is stored in your state associated with the resources, you'll need to get someone with a non M1 mac to run a
pulumi up
c

curved-summer-41191

01/06/2022, 4:21 PM
oh okay that makes sense, I didn't realize pulumi did that. Thanks again!
b

billowy-army-68599

01/06/2022, 4:21 PM
remember you can pass explicit providers to resources, so the version is important
you can also modify the state yourself manually, but I wouldn't recommend it 🙂
👍 1
2 Views