https://pulumi.com logo
#google-cloud
Title
# google-cloud
f

future-window-78560

04/18/2022, 10:41 AM
Hi, I have created database of postgresql instance. Adding allow_connections property to database as per docs,
Copy code
allow_connections=True,
The code:
Copy code
main = gcp.sql.DatabaseInstance("postgresinstance",
    database_version="POSTGRES_12",
    region="us-central1",
    deletion_protection=False,
   # deletion_protection=False,
    settings=gcp.sql.DatabaseInstanceSettingsArgs(

        tier="db-f1-micro",
    ))
    database = gcp.sql.Database("database", 
    instance=main.name,
    allow_connections=True,
    )
Any guide on how to get rid of this error: anaconda3/lib/python3.9/site-packages/pulumi_gcp/sql/database.py", line 386, in init self._internal_init(resource_name, *args, **kwargs) TypeError: _internal_init() got an unexpected keyword argument 'allow_connections'
2 Views