https://pulumi.com logo
#kubernetes
Title
# kubernetes
a

ambitious-fireman-71676

02/25/2020, 2:18 AM
im curious if anyone else has seen this aside from me. i’m trying to use a remote yaml in a resource using the python sdk
Copy code
from pulumi_kubernetes.yaml import ConfigFile

cert_manager_resources = ConfigFile('cert-manager',
    file_id='<https://github.com/jetstack/cert-manager/releases/download/v0.13.1/cert-manager.yaml>')
but when i run
pulumi preview
i get an exception:
Copy code
Exception: Exception deserializing response!
i wanted to double-check that the cert-manager guys are putting out valid yaml, and when i put it in a site like https://codebeautify.org/yaml-validator it’s actually not valid
this is curious to me since i’ve seen several posts of other users using the typescript sdk for setting up
cert-manager
without issue…
but the yaml is invalid…?
although i do see they specify
kubectl apply --validate=false <https://github.com/jetstack/cert-manager/releases/download/v0.13.1/cert-manager.yaml>
on their website https://cert-manager.io/docs/installation/kubernetes/
g

gorgeous-egg-16927

02/25/2020, 3:56 PM
It looks like you’re hitting https://github.com/pulumi/pulumi-kubernetes/issues/984 I merged the fix for that yesterday, and will be cutting a new release today. If you want to test out the fix in the meantime, https://pypi.org/project/pulumi-kubernetes/1.6.0a1582576303/ should work
a

ambitious-fireman-71676

02/25/2020, 3:57 PM
ohhh nice. i was searching the GH issues for open ones only
thanks!
👍 1
g

gorgeous-egg-16927

02/25/2020, 5:38 PM
a

ambitious-fireman-71676

02/25/2020, 5:39 PM
oh nice. i confirmed that the link before worked
👍 1
3 Views