https://pulumi.com logo
#kubernetes
Title
# kubernetes
h

hundreds-receptionist-31352

05/06/2020, 5:11 PM
Copy code
import * as k8s from "@pulumi/kubernetes";
// Deploy the latest version of the stable/wordpress chart.
const wordpress = new k8s.helm.v2.Chart("wpdev", {
    repo: "stable",
    chart: "wordpress",
    version: "2.1.3",
});
// Export the public IP for WordPress.
const frontend = wordpress.getResource("v1/Service", "wpdev-wordpress");
export const frontendIp = frontend.status.loadBalancer.ingress[0].ip;
b

billowy-army-68599

05/06/2020, 6:14 PM
can you show the output of your
pulumi up
?
h

hundreds-receptionist-31352

05/07/2020, 11:47 AM
Hi , Im getting
ubectl logs -f wordpress-wordpress-68d48b9945-qn6wf Welcome to the Bitnami wordpress container Subscribe to project updates by watching https://github.com/bitnami/bitnami-docker-wordpress Submit issues and feature requests at https://github.com/bitnami/bitnami-docker-wordpress/issues WARN  ==> You set the environment variable ALLOW_EMPTY_PASSWORD=yes. For safety reasons, do not use this flag in a production environment. nami    INFO  Initializing apache apache  INFO  ==> Reconfiguring PID file location... nami    INFO  apache successfully initialized nami    INFO  Initializing php nami    INFO  php successfully initialized nami    INFO  Initializing mysql-client nami    INFO  mysql-client successfully initialized nami    INFO  Initializing wordpress mysql-c INFO  Trying to connect to MySQL server mysql-c INFO  Found MySQL server listening at wordpress-mariadb:3306 mysql-c INFO  MySQL server listening and working at wordpress-mariadb:3306 Error executing 'postInstallation': You should specify username, password, host, port for SMTP configuratio
b

billowy-army-68599

05/07/2020, 12:07 PM
it looks like the chart has had quite a few updates since this version, can you try changing the version to
9.0.3
and re run pulumi up
h

hundreds-receptionist-31352

05/07/2020, 12:36 PM
okay let me see
this pod never up -> kubectl logs -f wordpress-mariadb-0 mariadb 160529.41 mariadb 160529.41 Welcome to the Bitnami mariadb container mariadb 160529.41 Subscribe to project updates by watching https://github.com/bitnami/bitnami-docker-mariadb mariadb 160529.41 Submit issues and feature requests at https://github.com/bitnami/bitnami-docker-mariadb/issues mariadb 160529.41 Send us your feedback at containers@bitnami.com mariadb 160529.41 mariadb 160529.41 INFO ==> * Starting MariaDB setup * mariadb 160529.45 INFO ==> Validating settings in MYSQL_*/MARIADB_* env vars mariadb 160529.45 INFO ==> Initializing mariadb database mariadb 160529.46 INFO ==> Using persisted data mariadb 160529.47 INFO ==> Running mysql_upgrade mariadb 160529.48 INFO ==> Starting mariadb in background mariadb 160530.50 INFO ==> Stopping mariadb
if it install it with helm command , it works
im using pulumi 2.0
I just evaluating to get the loadbalancer after a ingress in installed , or services , is not that I want to use wordpress , just was that example in pulumi web page , and tried it , and don't know if its a pulumi bug or another thing
b

billowy-army-68599

05/07/2020, 5:34 PM
What helm command are you using?
h

hundreds-receptionist-31352

05/07/2020, 6:01 PM
helm install --name myws bitnami/wordpress --version "9.0.4"
any idea? I have tried some others versions and I couldnt get it working
b

billowy-army-68599

05/08/2020, 4:26 PM
where are you running this? minikube?
h

hundreds-receptionist-31352

05/08/2020, 5:04 PM
no no , all against EKS
4 Views