Title
w

wet-noon-14291

11/01/2020, 11:07 PM
Is there a way to timeout a deploy to kubernetes faster if sometehing isn't correct?
b

billowy-army-68599

11/01/2020, 11:15 PM
do you mean if a deployment doesn't become healthy?
w

wet-noon-14291

11/01/2020, 11:17 PM
yes
b

billowy-army-68599

11/01/2020, 11:29 PM
add
<http://pulumi.com/skipAwait|pulumi.com/skipAwait>: "true"
to the resources annotations
w

wet-noon-14291

11/01/2020, 11:32 PM
is that documented anywhere? And what does it do? I do want to wait, but not for as long.
you can also use
<http://pulumi.com/timeoutSeconds|pulumi.com/timeoutSeconds>
w

wet-noon-14291

11/01/2020, 11:39 PM
I was about to post that 🙂
thanks
b

billowy-army-68599

11/01/2020, 11:40 PM
w

wet-noon-14291

11/01/2020, 11:51 PM
hm. I set it on the deployment and it is propagated down to the pod... but it still waits a long time before failing
apiVersion: v1
kind: Pod
metadata:
  annotations:
    <http://linkerd.io/created-by|linkerd.io/created-by>: linkerd/proxy-injector stable-2.8.1
    <http://linkerd.io/identity-mode|linkerd.io/identity-mode>: default
    <http://linkerd.io/proxy-version|linkerd.io/proxy-version>: stable-2.8.1
    <http://pulumi.com/timeoutSeconds|pulumi.com/timeoutSeconds>: "60"
  creationTimestamp: "2020-11-01T23:45:50Z"
I guess that is correct?
b

billowy-army-68599

11/01/2020, 11:51 PM
try setting it on the service
w

wet-noon-14291

11/01/2020, 11:51 PM
ok, thanks
g

gorgeous-egg-16927

11/02/2020, 4:39 PM
The
timeoutSeconds
annotation should still work, but you can have more fine-grained control using the
customTimeouts
options on any resource. (That option didn’t exist when the blog post Lee linked was written) https://www.pulumi.com/docs/reference/pkg/nodejs/pulumi/pulumi/#CustomResourceOptions-customTimeouts
b

billowy-army-68599

11/02/2020, 5:34 PM
ooh TIL, thanks @gorgeous-egg-16927