https://pulumi.com logo
#kubernetes
Title
# kubernetes
b

big-potato-91793

12/03/2020, 1:34 PM
Getting an error and trying to find why
c

cool-fireman-90027

12/03/2020, 1:34 PM
Can you post the error.
b

big-potato-91793

12/03/2020, 1:43 PM
Copy code
Error: Cannot find module './package.json'
     Require stack:
     - /builds/tm1-marketing/elasticsearch-datastore/exporter/node_modules/@ticketmaster/pulumi-tm-prometheus/build/utilities.js
     - /builds/tm1-marketing/elasticsearch-datastore/exporter/node_modules/@ticketmaster/pulumi-tm-prometheus/build/provider.js
     - /builds/tm1-marketing/elasticsearch-datastore/exporter/node_modules/@ticketmaster/pulumi-tm-prometheus/build/index.js
     - /builds/tm1-marketing/elasticsearch-datastore/exporter/node_modules/@ticketmaster/pulumi-tm-k8s/build/index.js
     - /builds/tm1-marketing/elasticsearch-datastore/exporter/index.ts
     - /builds/tm1-marketing/elasticsearch-datastore/exporter/node_modules/@pulumi/pulumi/cmd/run/run.js
     - /builds/tm1-marketing/elasticsearch-datastore/exporter/node_modules/@pulumi/pulumi/cmd/run/index.js
         at Function.Module._resolveFilename (internal/modules/cjs/loader.js:962:15)
         at Function.Module._load (internal/modules/cjs/loader.js:838:27)
         at Module.require (internal/modules/cjs/loader.js:1022:19)
         at require (internal/modules/cjs/helpers.js:72:18)
         at Object.getVersion (/builds/tm1-marketing/elasticsearch-datastore/exporter/node_modules/@ticketmaster/pulumi-tm-prometheus/build/utilities.js:43:19)
         at new PrometheusRule (/builds/tm1-marketing/elasticsearch-datastore/exporter/node_modules/@ticketmaster/pulumi-tm-prometheus/build/monitoring/v1/prometheusRule.js:56:38)
         at Object.<anonymous> (/builds/tm1-marketing/elasticsearch-datastore/exporter/index.ts:263:18)
         at Module._compile (internal/modules/cjs/loader.js:1118:30)
         at Module.m._compile (/builds/tm1-marketing/elasticsearch-datastore/exporter/node_modules/ts-node/src/index.ts:439:23)
         at Module._extensions..js (internal/modules/cjs/loader.js:1138:10)
we are using the crd2pulumi to genereate prom crds but for the reason he try to take the version of the package.json
i found the error on this but getting this after
Copy code
Updating (nonprod):
     pulumi:pulumi:Stack exporter-nonprod running 
     pulumi:providers:kubernetes default_2_7_0  error: no resource plugin 'kubernetes-v2.7.0' found in the workspace or on your $PATH, install the plugin using `pulumi plugin install resource kubernetes v2.7.0`
     pulumi:pulumi:Stack exporter-nonprod  
     pulumi:providers:kubernetes default_2_7_0 **failed** 1 error
  
 Diagnostics:
   pulumi:providers:kubernetes (default_2_7_0):
     error: no resource plugin 'kubernetes-v2.7.0' found in the workspace or on your $PATH, install the plugin using `pulumi plugin install resource kubernetes v2.7.0`
I already have the k8s pluign installed.
c

cool-fireman-90027

12/03/2020, 2:35 PM
What shows up when you run: `
Copy code
pulumi plugin ls -p
Can you try this: •
pulumi plugin install resource kubernetes v2.7.2
It could be related to this: https://github.com/pulumi/pulumi/issues/5619
b

big-potato-91793

12/03/2020, 2:45 PM
Copy code
$ npm ci
 > protobufjs@6.10.1 postinstall /builds/tm1-marketing/elasticsearch-datastore/exporter/node_modules/protobufjs
 > node scripts/postinstall
 > @pulumi/kubernetes@v2.4.3 install /builds/tm1-marketing/elasticsearch-datastore/exporter/node_modules/@pulumi/kubernetesx/node_modules/@pulumi/kubernetes
 > node scripts/install-pulumi-plugin.js resource kubernetes v2.4.3
 [resource plugin kubernetes-2.4.3] installing
 Downloading plugin: 26.53 MiB / 26.53 MiB  100.00% 1s
 > @pulumi/kubernetes@v2.7.2 install /builds/tm1-marketing/elasticsearch-datastore/exporter/node_modules/@pulumi/kubernetes
 > node scripts/install-pulumi-plugin.js resource kubernetes v2.7.2
 [resource plugin kubernetes-2.7.2] installing
 Downloading plugin: 30.12 MiB / 30.12 MiB  100.00% 0s
 added 277 packages in 6.234s
3 Views