https://pulumi.com logo
#kubernetes
Title
# kubernetes
r

red-area-47037

12/18/2020, 6:39 PM
Hi, we use Pulumi to also deploy a few charts to our Kubernetes cluster. So far that worked well, but to day when updating the certmanager Helm-Chart from version 2.3.4 to 3.0.0 we ran into a problem (although on other system the update worked without a problem.
Copy code
kubernetes:<http://apiextensions.k8s.io/v1:CustomResourceDefinition|apiextensions.k8s.io/v1:CustomResourceDefinition> (<http://certificates.cert-manager.io|certificates.cert-manager.io>):
    error: 1 error occurred:
    	* the Kubernetes API server reported that "<http://certificates.cert-manager.io|certificates.cert-manager.io>" failed to fully initialize or become live:  "" is invalid: patch: Invalid value: ......." : cannot convert int64 to float64
I think this is the underlaying problem: https://github.com/helm/helm/issues/5806
I ended up commenting the cert-manager helm chart commands in Pulumi and running
pulumi up
and then uncommenting them again followed by another
pulumi up
forcing a delete and new deployment of the cert-manager Helm-Chart. This worked without impacting the services running but didnt felt right 😞 Anyone ran into similar problems and how did you fixed them... Trying to build up more knowledge to prepare for production level deployments soon...
3 Views