https://pulumi.com logo
#kubernetes
Title
# kubernetes
b

busy-soccer-65968

03/31/2021, 4:47 PM
Anyone ever experience a refresh on a helm chart causing pulumi to think
apiVersion
on an ingress is different than what it actually is. Basically in reality my ingress is
extensions/v1beta1
but when I refresh pulumi changes state to
<http://networking.k8s.io/v1|networking.k8s.io/v1>
and then when I preview it shows it wanting to change it to
extensions/v1beta1
which it already is... I'm also seeing this
Ingress has at least one rule that does not target any Service. Field '.spec.rules[].http.paths[].backend.serviceName' may not match any active Service
which is also around this helmchart and ingress. I found an issue form 2020 around this. Basically then it was simply a misconfigured helmchart. However, I have confirmed that my labels are correct and my label selectors all line up.
I believe it is all related because the spec path changes from
serviceName
to
service.name
in the newer api.
and i'm also seeing
Copy code
No matching service found for ingress rule: "<http://topsecret.stage.myrootdomain.net|topsecret.stage.myrootdomain.net>" -> ""
which leads me to believe it's getting undefined trying to access the incorrect property.
we recently bumped our kube api in eks from 1.14 --> 1.19 so I know this has some deprecated and removed API things as well. however, I wouldn't think deprecated would mean not working.
the helm chart ingress is also
apiVersion: extensions/v1beta1
so I really have no idea where pulumi is deciding oh wait a second this is the new api
it just hangs
Copy code
`  No matching service found for ingress rule:
but it's not true. the service is found and the ingress even works
f

future-refrigerator-88869

03/31/2021, 8:21 PM
I had the same thing. ingress worked but the console was complaining and hanging. Changing the definition from the v1beta to this, worked fine.
Copy code
new k8s.networking.v1.Ingress(...)
b

busy-soccer-65968

03/31/2021, 8:23 PM
damn, glad to know... sadly i'm using a helm chart and isn't the new version. I'll try a transformation.
definitely something strange in the ingress await logic. can't figure out what. https://github.com/pulumi/pulumi-kubernetes/blob/536b37bb61cc6f9d6a041748ad96a575aebeef44/provider/pkg/await/ingress.go . Somewhere around
Copy code
checkIfEndpointsReady
Even tried SkipAwait:true annotation and it didn't help```
6 Views