https://pulumi.com logo
#aws
Title
# aws
l

little-cartoon-10569

09/24/2020, 3:09 AM
I have moved my SQL Server RDS instance from one project to another. That has involved various stack import/change/export iterations, to get the name and identifier values from the old stack to be used successfully in the new stack, so that Pulumi doesn't try to delete my database. (It's pretty laborious stuff, and I can't use "alias" because the code is in a ComponentResource that is shared between multiple stacks, so there are multiple "aliases" involved). The process has worked for lots of other resources, and seems to have worked for this DB. But somehow I've got myself into a situation where any updates detected by Pulumi cause this exception:
panic: fatal: An assertion has failed: Expected diff to not require deletion or replacement during Update of urnpulumicore:shared resourcespamsaws:ManagedDb$awsrds/instanceInstance::mydb
Could this have something to do with my domain? SQL Server is connected to a DC in the same VPC, and I'm getting this error in the same
pullumi up
calls:
awsdirectoryserviceLogService (mydomain):
error: connection error: desc = "transport: Error while dialing dial tcp 127.0.0.134623 connect: connection refused"
Oh, and this one from RDS:
awsrdsInstance (mydb):
error: transport is closing
I noticed it had a bad log group (it was using the name of a log group that was deleted yesterday.. no referential integrity!). When I fixed that, the problem went away. Looks like the problem wasn't with making the change, it was with reporting the change to Cloud Watch! And that caused the action to abort.