https://pulumi.com logo
#aws
Title
# aws
q

quaint-portugal-34880

10/06/2020, 10:45 PM
I have issues with creating an EKS cluster, I get this error
aws:cloudformation:Stack (process-cluster-nodes):
error: 1 error occurred:
* creating urn:pulumi:eks-process-cluster-cdev::eks-process-cluster::eks:index:Cluster$aws:cloudformation/stack:Stack::process-cluster-nodes: 1 error occurred:
* ROLLBACK_COMPLETE: ["The following resource(s) failed to create: [NodeGroup]. . Rollback requested by user." "The requested configuration is currently not supported. Please check the documentation for supported configurations. Launching EC2 instance failed."]
error: update failed
error: Running program '/process-cluster/pulumi' failed with an unhandled exception:
TypeError: Cannot use 'in' operator to search for 'NodeGroup' in undefined
Any idea what is wrong?
l

little-cartoon-10569

10/06/2020, 10:48 PM
Some variable had no value. You are expecting something to be a collection, but it is
undefined
.
Cannot use 'in' operator to search ... in undefined
q

quaint-portugal-34880

10/06/2020, 10:52 PM
Could it be that the default instance type is not supported in the region where I run it?
Yes verified now, the region eu-north-1 don't have support for t2.medium, worked when I set instanceType: "t3.medium"
👍 1
l

little-cartoon-10569

10/06/2020, 11:14 PM
t2 is pretty old...