https://pulumi.com logo
#aws
Title
# aws
l

little-cartoon-10569

11/06/2020, 12:53 AM
pulumi preview -v 9
is reporting this error:
error: awsec2/instanceInstance resource 'preprod-batch' has a problem: Computed attribute cannot be set
Nothing else. No idea how to tell which property or what value. It's in code that hasn't changed in days. Any idea if recent changes to Pulumi or the AWS provider might cause previously-valid config to become invalid?
I can't find "Computed attribute cannot be set" in any code... I've looking in pulumi, pulumi-aws, pulumi-terraform-bridge...
g

gentle-diamond-70147

11/06/2020, 1:49 AM
what version of pulumi/pulumi and cli are you on?
l

little-cartoon-10569

11/06/2020, 1:51 AM
I had just upgraded the CLI to 2.13.0. Looks like pulumi/pulumi is 2.12.1.
Yep, lock file says 2.12.1.
g

gentle-diamond-70147

11/06/2020, 1:54 AM
if you downgrade the cli to 2.12.1, do you still get this?
l

little-cartoon-10569

11/06/2020, 1:55 AM
I'll check asap.. in a meeting right now.
Checked. Still happens in 2.12.1.
Trying destroy/re-up.
Worked fine there.. and now the computed field isn't changing, so no more error message...
g

gentle-diamond-70147

11/06/2020, 3:00 AM
😕
w

wooden-school-36855

11/24/2020, 2:55 AM
i got same error pay-dev-eks-cluster (awseksCluster) error: awseks/clusterCluster resource ‘eks-cluster’ has a problem: Computed attribute cannot be set pulumi v2.14.0
Copy code
eks.NewCluster(ctx, "eks-cluster", &eks.ClusterArgs{
   RoleArn: pulumi.StringInput(eksRole.Arn),
   VpcConfig: &eks.ClusterVpcConfigArgs{
      PublicAccessCidrs: pulumi.StringArray{pulumi.String("0.0.0.0/0")},
      SecurityGroupIds:  pulumi.StringArray{groupIds},
      SubnetIds:         subnetIds,
      VpcId:             vpc.ID(),
   },
before i add
VpcId
not show
Computed attribute cannot be set
with me.