https://pulumi.com logo
Title
q

quick-apartment-308

11/06/2020, 8:59 PM
Hi all, I’m getting an unusual error that can’t be reproduced on any of my coworker’s machines:
Error: Running program '/services/legacy-alert-sync' failed with an unhandled exception:
    Error: Unable to deserialize resource urn:pulumi:dev::legacy-alert-sync::aws:iam/role:Role::legacy-alert-sync-dev-legacyAlertSync, no module is registered for iam/role.
Has anyone seen something like this?
b

billowy-army-68599

11/06/2020, 9:13 PM
this is a bug in pulumi 2.13.0, if you downgrade it should be fixed. sorry about this. The issues is here: https://github.com/pulumi/pulumi/issues/5705#issuecomment-723302264 with a workaround
q

quick-apartment-308

11/07/2020, 3:16 AM
Worked, thank you!
g

gentle-diamond-70147

11/07/2020, 2:56 PM
This should be fixed in the latest 2.13.2 Pulumi release.
👀 1