https://pulumi.com logo
#aws
Title
# aws
s

salmon-ghost-86211

01/29/2021, 11:12 PM
I have an existing EKS cluster with an unmanaged nodegroup created using the
createNodeGroup
function. I changed the
desiredCapacity
and then looked at the Details of what
pulumi up
wanted to change. I notice the templateBody for the Cloudformation stack has data like this
Copy code
AWSTemplateFormatVersion: '2010-09-09'
                Outputs:
                    NodeGroup:
                        Value: !Ref NodeGroup
                Resources:
                    NodeGroup:
                        Type: AWS::AutoScaling::AutoScalingGroup
                        Properties:
                          DesiredCapacity: 7
                          LaunchConfigurationName: ...
                          MinSize: 7
                          MaxSize: 10
                          VPCZoneIdentifier: [...]
                          Tags:
                          ...
                        UpdatePolicy:
                          AutoScalingRollingUpdate:
                            MinInstancesInService: '1'
                            MaxBatchSize: '1'
Some details are redacted with
...
. My question... how do we change the
UpdatePolicy
listed at the bottom? I need
MinInstancesInService
to be much higher, but I don't see it as an option to pass when I look at
<https://www.pulumi.com/docs/reference/pkg/nodejs/pulumi/eks/#NodeGroupOptions>
Bumping to see if anyone has any ideas...
b

billowy-army-68599

02/02/2021, 12:09 AM
I dont' think this option is exposed in the eks library, if you need it, you'll have to create your own nodegroup
s

salmon-ghost-86211

02/02/2021, 3:17 PM
Thanks