:wave: hello, just trying out the <aws-ts-static-...
# aws
πŸ‘‹ hello, just trying out the aws-ts-static-website example with out of the box with config set and running into a hanging
pulumi up
with no real idea what the holdup is - what can i do to determine why this is hanging for 30 minutes or more? attached output and also with
file. nothing is being created in aws.
interesting, it took 48 minutes for the debug output to give me a
Copy code
failed getting account information via iam:GetUser: ExpiredToken: The security token included in the request is expired
forgot a
pulumi config set aws:profile name
! πŸ€¦β€β™‚οΈ
ok, got the right dns zone ID, but now hanging again for 15+ minutes on
Copy code
I0228 11:28:55.823052   78069 eventsink.go:62] eventSink::Debug(<{%reset%}>Registering resource: t=aws:route53/record:Record, name=********.com, custom=true, remote=false<{%reset%}>)
looks like it's isolated to the ACM cert creation. commenting all but the s3 buckets allowed them to be created. now just goes silent for minutes on end after grabbing the right zone file info. been 10 minutes. is this example still the best way to get a cert and validation records set up? https://github.com/pulumi/examples/blob/master/aws-ts-static-website/index.ts#L88
i based my own static site deployment off of that script, including the cert generation, etc.. that part is definitely the slowest and can take a few minutes at least.. though i don't think i've waited 10+
thanks, i gave in and manually created the cert and provided an ARN, which worked great. would still like to get the cert and validation into pulumi but not a huge deal at the moment, wonder if it's a module incompat with newer
i haven't tried mine for a little bit; will have to see if that's the case when i have a bit of free time
The cert taking >15 mins is expected on AWS - though we should likely make that not the default in that example (or warn about how long it will take!). The hang when you have expired credentials is something we would definitely like to fix - it’s due to the issue tracked in https://github.com/pulumi/pulumi-aws/issues/814#issuecomment-597991455.
πŸ‘ 1