https://pulumi.com logo
#aws
Title
# aws
w

white-secretary-18260

08/04/2021, 4:03 PM
How does one update the version of the
plugin for aws provider
we are stuck on
3.32.0
and there is not apple/arm version of that plug-in. We’d like to update to
3.38.1
and we did so in the package.json file, but we are still getting:
Copy code
error: could not load plugin for aws provider 'urn:pulumi:master::alphamap::pulumi:providers:aws::default_3_32_0': no resource plugin 'aws-v3.32.0' found in the workspace or on your $PATH, install the plugin using `pulumi plugin install resource aws v3.32.0`
s

steep-toddler-94095

08/04/2021, 4:58 PM
run
yarn upgrade @pulumi/aws
(or
npm
if you don't use
yarn
)
just updating the package.json won't upgrade it because your lockfile pins it to 3.32
b

billowy-army-68599

08/04/2021, 5:15 PM
you'll need to get someone without an arm laptop to update it 😞
w

white-secretary-18260

08/04/2021, 6:00 PM
Hey, we did install via yarn to update the
package.json
and
yarn.lock
files, and ran
pulumi up
in our build container (ran on debian x86) and we are still getting this error.
is it maybe we are still on
"@pulumi/pulumi": "2.22.0"
?
b

billowy-army-68599

08/04/2021, 6:03 PM
@white-secretary-18260 you need both the old and the new provider to do the update, so run the command it's asking you to run, and the state will get updated and use the newest version
w

white-secretary-18260

08/04/2021, 6:05 PM
We are not getting this error in our CI. only on Apple silicon.
b

billowy-army-68599

08/04/2021, 6:08 PM
it's hard to determine where the dependency is coming from, can you share your package.json and yarn.lock files?
w

white-secretary-18260

08/04/2021, 7:14 PM
the
yarn.lock
is for a large mono-repo, too long to put here, I will post the relevant sections: yarn.lock:
Copy code
"@pulumi/aws@3.38.1":
  version "3.38.1"
  resolved "<https://registry.yarnpkg.com/@pulumi/aws/-/aws-3.38.1.tgz#d7972f82bebc2205622d8283b0983e96a36f7c94>"
  integrity sha512-XnCa7AHq+/Py/eHItlus+YTjelKEn77u9ffO+owjrucb8RRhkvDzAa3prjQbhrRDxBvwZ7GcQqp/5SGTamkboQ==
  dependencies:
    "@pulumi/pulumi" "^2.17.0"
    aws-sdk "^2.0.0"
    builtin-modules "3.0.0"
    mime "^2.0.0"
    read-package-tree "^5.2.1"
    resolve "^1.7.1"

"@pulumi/awsx@0.25.0":
  version "0.25.0"
  resolved "<https://registry.yarnpkg.com/@pulumi/awsx/-/awsx-0.25.0.tgz#59bdfa30d61e13ebbb8a5f6c2ef4f31a4f63fdc4>"
  integrity sha512-J9xLnOjew46Y4qxIE7jv9K0KgQDCicK75hUW/IRE95wFPWUxq7QCGczEPHXcNyZydebcr0VGRA9G2xjODUqczA==
  dependencies:
    "@pulumi/docker" "^1.0.0 || ^2.0.0"
    "@types/aws-lambda" "^8.10.23"
    mime "^2.0.0"

"@pulumi/docker@^1.0.0 || ^2.0.0":
  version "2.10.0"
  resolved "<https://registry.yarnpkg.com/@pulumi/docker/-/docker-2.10.0.tgz#cac544739261be10268e3bb044fe7a6e100193c3>"
  integrity sha512-nZkZpAd1FuOWjms5FlrA5BK++Mwp3rQn+7U/oEpHcGCGzKBm8Xsi0gGzBzfHZXlpxRg3tLGQLcDdHM1seV8QVQ==
  dependencies:
    "@pulumi/pulumi" "^2.15.0"
    semver "^5.4.0"

"@pulumi/pulumi@2.22.0":
  version "2.22.0"
  resolved "<https://registry.yarnpkg.com/@pulumi/pulumi/-/pulumi-2.22.0.tgz#6c86ce4682d5d2b4e4948a9f3f50f51761deb928>"
  integrity sha512-a4RFbb7Ly7aa+rlypIBVHUByFa8qwY0mRStRqGT/xPiO8MZ957b1uCK60pOniPGe6sSYQ6tz/HGweRlpP18pcA==
  dependencies:
    "@grpc/grpc-js" "^1.2.7"
    "@pulumi/query" "^0.3.0"
    google-protobuf "^3.5.0"
    js-yaml "^3.14.0"
    minimist "^1.2.0"
    normalize-package-data "^2.4.0"
    protobufjs "^6.8.6"
    read-package-tree "^5.3.1"
    require-from-string "^2.0.1"
    semver "^6.1.0"
    source-map-support "^0.4.16"
    ts-node "^7.0.1"
    typescript "~3.7.3"
    upath "^1.1.0"

"@pulumi/pulumi@^2.15.0", "@pulumi/pulumi@^2.17.0":
  version "2.25.2"
  resolved "<https://registry.yarnpkg.com/@pulumi/pulumi/-/pulumi-2.25.2.tgz#8ef5a921302d26ba1220169cefc92620c1192642>"
  integrity sha512-JVPkxr2zt44fsUbqrW0yW2jTcsCXXEwJfOged+2dgXheYBHNdaGtdZgaHXi4lr21tm5ddZEdtwY6i5rDAblyQw==
  dependencies:
    "@grpc/grpc-js" "^1.2.7"
    "@logdna/tail-file" "^2.0.6"
    "@pulumi/query" "^0.3.0"
    google-protobuf "^3.5.0"
    js-yaml "^3.14.0"
    minimist "^1.2.0"
    normalize-package-data "^2.4.0"
    protobufjs "^6.8.6"
    read-package-tree "^5.3.1"
    require-from-string "^2.0.1"
    semver "^6.1.0"
    source-map-support "^0.4.16"
    split2 "^3.2.2"
    ts-node "^7.0.1"
    typescript "~3.7.3"
    upath "^1.1.0"

"@pulumi/query@^0.3.0":
  version "0.3.0"
  resolved "<https://registry.yarnpkg.com/@pulumi/query/-/query-0.3.0.tgz#f496608e86a18c3dd31b6c533408e2441c29071d>"
  integrity sha512-xfo+yLRM2zVjVEA4p23IjQWzyWl1ZhWOGobsBqRpIarzLvwNH/RAGaoehdxlhx4X92302DrpdIFgTICMN4P38w==
and from the package.json:
Copy code
"dependencies": {
        "@pulumi/aws": "3.38.1",
        "@pulumi/awsx": "0.25.0",
        "@pulumi/pulumi": "2.22.0",
        "@types/mime": "^2.0.3",
        "mime": "^2.5.2"
    },
😕 think we found it… in a base image of our build container we are installing 3.32.0, that was probably it.
2 Views