I suddenly start to get a very strange error with ...
# aws
I suddenly start to get a very strange error with my s3 state bucket
/tmp/pulumi % pulumi up
error: failed to load checkpoint: blob (key ".pulumi/stacks/test-stack.json") (code=Unknown): ExpiredToken: The provided token has expired.
status code: 400, request id: WD9TGHZYT1S0D2DA, host id: LG3ktEVsZRP1DTG47uiEWrC+ez4t4X0COr65CqkGxTTMiKhpygCnWbQKUhBI3TSMIYf6nqSTdNo=
I have logged in with pulumi login s3://my-state-bucket And cmds like aws s3 --profile my-profile ls s3://my-state-bucket works fine The only AWS env variable is AWS_PROFILE=my-profile I get the same error with all my stacks and it started suddenly Running latest version of Pulumi
can you confirm your access keys are still valid with the aws cli directly? e.g.
aws s3 ls
Yes, And cmds like aws s3 --profile my-profile ls s3://my-state-bucket works fine
I tried to run with --verbose 10 as well but no debug info
Can you confirm that state file exists in the bucket?
aws s3 ls <s3://my-state-bucket/.pulumi/stacks/test-stack.json>
or in the AWS Console
Yes it does and I can copy it to my local computer
I found the problem I was logged in to the wrong bucket I had done pulumi login s3://my-state-buckets with an extra s instead of my-state-bucket
The pulumi login cmd didn't respond with an error when I logged in to an non-existing bucket
Hmm, yea, that's unfortunate.