Hello, my api management service has stopped worki...
# azure
Hello, my api management service has stopped working since tuesday when I updated to pulumi 2.0 locally. Here is my the service that I'm trying to create that has succeded in the past:
let service2 = new azure.apimanagement.Service("testams", {
resourceGroupName: "ddm-te-dev",
skuName: "Developer_1",
publisherName: "YourCompany",
publisherEmail: "<mailto:api@yourcompany.com|api@yourcompany.com>"
}, { customTimeouts: { create: "59m" } });
The error i get it: azureapimanagementService (testams): error: unexpected unknown property value When I run pulumi preview it doesn't complain. Could you help me with this?
Hey @handsome-optician-50551 Sorry for the issue here - what version of Pulumi and Pulumi-azure are you using? Paul
not sure where I can see the Pulumi-azure version
it downloads a resource plugin azure-2.1.0 if that is what you are referring too
Ok that’s the info we need - I’ll try and figure it out. Have you recently upgraded?
My pipeline was set to latest for version but updated locally 2 days ago and thats when I noticed it
Before that I hadn't worked with it for 5 days maybe
@broad-dog-22463 Hi, did you find an bug?
@broad-dog-22463 Any update on the issue?
Hi @handsome-optician-50551 My apologies - I really thought I had responsed here to you - so I ran this exact same code as above and got the same error.:
Copy code
Do you want to perform this update? yes
Updating (dev):
     Type                            Name            Status         Info
 +   pulumi:pulumi:Stack             apiservice-dev  created
     └─ azure:apimanagement:Service  testams         **failed**     1 error

  azure:apimanagement:Service (testams):
    error: unexpected unknown property value
Thanks atleast now i know 🙂. How do I write the following? curl -fsSL https://get.pulumi.com/ | bash --version 1.14.1 i'm not sure where to put the version
curl -fsSL https://get.pulumi.com | sh -s -- --version "2.0.0-beta.2"
thank you 😄
I tried running the older version aswell back to 1.12.1 and got the same error