06/23/2020, 2:33 PM
[SOLVED] Hello guys! Im stucked on weird issue and i'm wondering, if somebody have ran into it before. I'm using Pulumi with
with Azure provider. I want to create new
with existing
on Azure (we are migrating as a company to Pulumi, but slowly and we still have some resources in the azure created manually). When i try to reference it as described here I get following error (i suppose from Azure api)
error: ID was missing the `serverfarms` element
But i'm sure, that the id is correct in form of:
And that it exists. Have somebody experienced this issue or do you have any hints what could be root cause of this error? Thanks for any insights / hints! 🙂
Ok, solved this already 🙂 (with using Pulumi's GetAppService Issue was, that when I've used the
from Azure Portal as i posted in original post it's a little bit different than the correct one. Diff is:
From Azure Portal (which does not work)

From GetAppService
‼️ Note the small 'f' in
Should I open an issue somewhere for this? 🙂