https://pulumi.com logo
#azure
Title
# azure
l

little-kangaroo-50941

06/26/2020, 1:21 PM
Hello and thanks in advance. In Pulumi Azure I need to import an existing sql azure in my stack. So I setup the admin username and password equal to the existing ones and found the correct ResourceId. But when I launch pulumi up to import the resource it says that administratorLoginPassword is different and the import fails. The password is stored as a secret config and I’m sure that matches…maybe is because the encrypted value is different? How I can manage?
t

tall-librarian-49374

06/26/2020, 1:47 PM
Would it work if you added this property to
ignoreChanges
resource options?
l

little-kangaroo-50941

06/26/2020, 2:39 PM
yes with the lowercase A in the name of the property 🙂
Copy code
new CustomResourceOptions
{
    ImportId = sqlConfig.Require("id"),
    IgnoreChanges = new List<string>
    {
        "administratorLoginPassword"
    }
}
as usual thank you Mikhail!
💯 1
b

brainy-garden-89849

07/15/2020, 8:42 PM
Brilliant, this answered my same issue
3 Views