03/16/2021, 5:18 PM
And this is why you run nightly builds and check for pulumi outdated packages. My nugets 🙂 were out of date. Now only a deprecation warning remains, but this I can handle 😄 original below. --- Out of nowhere I am getting errors when creating role assignments. The first time I get a 404:
error: authorization.RoleAssignmentsClient#Get: Failure responding to request: StatusCode=404 -- Original Error: autorest/azure: Service returned an error. Status=404 Code="RoleAssignmentNotFound" Message="The role assignment '<GUID>' is not found."
And if I run it again:
StatusCode=409 -- Original Error: autorest/azure: Service returned an error. Status=409 Code="RoleAssignmentExists" Message="The role assignment already exists."
Edit: just to point out, this is code that previously worked correctly, I am deploying a cluster and assigning roles for a registry and for a "Network Contributor". Both role assignment creations fail now, I guess they did not get created in time or something along those lines.