https://pulumi.com logo
Title
s

strong-park-55853

09/06/2021, 4:18 PM
Hi, I’m working on a slightly older pulumi stack that is using an older provider version than I have installed locally. I received an error for the missing provider plugin & this error from the install command:
pulumi plugin install resource azure v3.42.0
[resource plugin azure-3.42.0] installing
error: [resource plugin azure-3.42.0] downloading from : 403 HTTP error fetching plugin from <https://get.pulumi.com/releases/plugins/pulumi-resource-azure-v3.42.0-darwin-arm64.tar.gz>
I checked the url for the current provider version and it seems to be available. Any help getting access to this version would make my life easier 🙂
b

billowy-army-68599

09/08/2021, 5:28 AM
hey @strong-park-55853 - we only started releasing arm versions of the azure plugin at 3.52. You'll have to update your provider references using a non arm machine
s

strong-park-55853

09/08/2021, 7:58 AM
@billowy-army-68599 Thanks, I was able to get a colleague to update the existing stack to a new provider version! Is this arm version support documented anywhere, might be worth adding it if not